存档

文章标签 ‘Ubuntu’

Ubuntu解决无法修改移动硬盘文件权限

2013年11月17日 sigma 没有评论 10,032 views

为了安全,ubuntu默认mount的移动硬盘文件权限是无法修改的,有时想直接在移动硬盘中执行文件,就需要能够修改权限。为了解决这矛盾,需要手动umount后,用以下命令手动mount。

mount /dev/hda1 /windows/c -t ntfs -o nls=utf-8,umask=000,uid=1000,gid=1000
分类: 沙子 标签: ,

停止支持的老版本ubuntu源列表-old-releases

2012年12月7日 sigma 没有评论 9,428 views

ubuntu的普通版本支持的时间都有限,过了支持的时间,更新源都会被停用,比如ubuntu9.10原来的源都失效了(包括官方源,类似ustc的第三方源,因为这些第三方源也是和官方源同步的)。因此,直接用原来的源列表是不能安装更新软件的。为了解决这个问题,ubuntu官方专门出了一个old-release的镜像(http://old-releases.ubuntu.com/),可以用这个源更新。比如9.10的源列表如下:

deb http://old-releases.ubuntu.com/ubuntu/ karmic main restricted universe multiverse
deb http://old-releases.ubuntu.com/ubuntu/ karmic-security main restricted universe multiverse
deb http://old-releases.ubuntu.com/ubuntu/ karmic-updates main restricted universe multiverse
deb http://old-releases.ubuntu.com/ubuntu/ karmic-proposed main restricted universe multiverse
deb http://old-releases.ubuntu.com/ubuntu/ karmic-backports main restricted universe multiverse
deb-src http://old-releases.ubuntu.com/ubuntu/ karmic main restricted universe multiverse
deb-src http://old-releases.ubuntu.com/ubuntu/ karmic-security main restricted universe multiverse
deb-src http://old-releases.ubuntu.com/ubuntu/ karmic-updates main restricted universe multiverse
deb-src http://old-releases.ubuntu.com/ubuntu/ karmic-proposed main restricted universe multiverse
deb-src http://old-releases.ubuntu.com/ubuntu/ karmic-backports main restricted universe multiverse

其他版本的只需要讲karmic改成其版本代号即可。这样过期后的版本也可以继续使用了。

分类: 贝壳 标签: ,

Ubuntu下消除耳机电流声的方法

2012年3月16日 sigma 没有评论 64,585 views

不知什么时候开始,我在ubuntu下用耳机听歌,经常听到电流声,很郁闷,上网搜了并亲自尝试了下,发现下面的方法有效:

1.中端输入sudo alsamixer回车-输入密码后进入alsa高级控制面板
2.按F5,显示所有音轨,左右键移动音轨,上下键调节音量,把每个出现红色的音量条调节到绿色.
3.这个实时生效的,关闭窗口,再听听有没有杂音?

来源:http://forum.ubuntu.org.cn/viewtopic.php?f=74&t=154080&start=0

分类: 沙子 标签: ,

Linux(ubuntu8.04)下载安装Matlab R2008a

2012年1月7日 sigma 没有评论 7,432 views

首先,下载,可以六维搜,或者其他地方搜种子,但是我很不幸,搜出来的结果全是没有速度的种子。

于是,我开始转向直接找ftp的文件,我相信很多高校ftp上应该有,于是用ftp搜索,如grid.ustc.edu.cn搜,很不幸没搜到。后来用http://www.goobye.net/才搜到一个不错的ftp链接。

后面就剩下下了,下午以后安装,基本按照下面链接就行了。

http://worldant.blog.sohu.com/93810662.html

 

分类: 沙子 标签: , ,

linux(Ubuntu)启用禁用面板(panel)

2011年12月30日 sigma 没有评论 4,300 views

我有个习惯,那就是打开任何程序都喜欢全屏,并且打开程序也喜欢用Alt+F2打开,因此,我的ubuntu完全没必要有上面和下面的面板(ubuntu上面的面板是方便打开各种程序,下面的面板相当于任务栏)。

很早以前,我就把我桌面的所有面板删除了,并且将桌面设成黑色。进去系统,输入用户名密码,一看到就是纯黑背景,需要打开程序的话,需要使用快捷键。但是,今天,不知道为什么,下面的面板又出现了,只好找了哥方法重新删除。

方法一:命令行:

首先,找到gconf中的关于面板list的value:

gconftool -g /apps/panel/general/toplevel_id_list

一般输出为:[bottom_panel_screen0,top_panel_screen0]

说明有两个panel,分别为top,bottom

重设,将两个都删除即可:

gconftool -s /apps/panel/general/toplevel_id_list -t string ""

方法二:图形方法:

Alt+F2,打开运行窗口,输入:gconf-editer;

然后找到/apps/panel/general/,编辑键值toplevel_id_list为空。

分类: 沙子 标签: , ,

Ubuntu刷新DNS缓存

2011年12月27日 sigma 没有评论 10,574 views

网上查了下,发现linux刷新dns的缓存方法都是:

sudo /etc/init.d/nscd restart

但是在我的机器上,发现提示命令找不到:

sudo: /etc/init.d/nscd: command not found

后来发现是需要先安装nscd包:

sudo apt-get install nscd

但我不想为此安装一个程序或服务,只好用最暴力的方法刷dns,重启网络:

sudo /etc/init.d/networking restart
分类: 沙子 标签: , , ,

Ubuntu 8.04(Hardy)安装scons 0.98

2011年9月15日 sigma 没有评论 5,018 views

今天需要用到M5,安装的时候发现需要scons,于是apt-get了一个,谁知还不能用,版本太低了,才0.97,而GEM5需要0.98以上的。

于是只好放弃从源里安装,自己找debian包安装,终于在这里https://launchpad.net/ubuntu/intrepid/hppa/scons/0.98.5-1ubuntu1 找到一个可用的debian包,版本为0.98.5,本来是hppa用的,但hardy也可以用。

 

分类: 编程相关 标签: , ,

无觅相关文章插件,快速提升流量